theta-packages.yaml 2.17 KB
Newer Older
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101
packages:
    all:
        providers:
            mpi: [mpich, openmpi]
        compiler: [gcc@7.3.0, intel@18.0.2.199, cce@8.7.3]
    autoconf:
        paths:
            autoconf@2.69: /usr
        buildable: False
    automake:
        paths:
            automake@1.13.4: /usr
        buildable: False
    binutils:
        paths:
            binutils@2.31.1: /usr
        buildable: False
    bison:
        paths:
            bison@2.7: /usr
        buildable: False
    boost:
        modules:
            boost@1.64.0 arch=cray-cnl6-mic_knl: boost/gnu/1.64.0
        buildable: False
    bzip2:
        paths:
            bzip2@1.0.6: /usr
        buildable: False
    ch-placement:
        version: [ develop ]
    cmake:
        modules:
            cmake@3.14.5: cmake/3.14.5
        buildable: False
    coreutils:
        paths:
            coreutils@8.25: /usr
        buildable: False
    cppunit:
        variants: cxxstd=14
    findutils:
        paths:
            findutils@4.5.12: /usr
        buildable: False
    flex:
        paths:
            flex@2.5.37: /usr
        buildable: False
    gettext:
        paths:
            gettext@0.19.2: /usr
        buildable: False
    git:
        paths:
            git@2.12.3: /usr
        buildable: False
    libfabric:
        variants: fabrics=tcp,rxm
    libtool:
        paths:
            libtool@2.4.2: /usr
        buildable: False
    m4:
        paths:
            m4@1.4.16: /usr
        buildable: False
    margo:
        version: [ develop ]
    mercury:
        variants: +udreg ~boostsys
    mpich:
        modules:
            mpich@7.7.3 arch=cray-cnl6-mic_knl: cray-mpich
        buildable: False
    perl:
        paths:
            perl@5.18.2: /usr
        buildable: False
    pkg-config:
        paths:
            pkg-config@0.29: /usr
        buildable: False
    sdskeyval:
        version: [ develop ]
    tar:
        paths:
            tar@1.27.1: /usr
        buildable: False
    texinfo:
        paths:
            texinfo@4.13: /usr
        buildable: False
    thallium:
        version: [ develop ]
    xz:
        paths:
            xz@5.0.5: /usr
        buildable: False
    yaml-cpp:
        version: [ develop ]