spack.yaml 2.54 KB
Newer Older
Matthieu Dorier's avatar
Matthieu Dorier committed
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120
spack:
  specs:
  - mochi-margo%gcc@9.1.0
  - mercury@master # 2.0.0rc1 doesn't build; remove this line when 2.0.0 comes out
  concretization: together
  compilers:
  - compiler:
      paths:
        cc: /sw/summit/gcc/9.1.0-alpha+20190716/bin/gcc
        cxx: /sw/summit/gcc/9.1.0-alpha+20190716/bin/g++
        f77: /sw/summit/gcc/9.1.0-alpha+20190716/bin/gfortran
        fc: /sw/summit/gcc/9.1.0-alpha+20190716/bin/gfortran
      operating_system: rhel7
      target: ppc64le
      modules:
      - gcc/9.1.0
      environment: {unset: []}
      extra_rpaths: []
      flags: {}
      spec: gcc@9.1.0
  repos:
  - /ccs/home/mdorier1/sds-repo
  packages:
    all:
      compiler: [gcc@9.1.0]
      providers:
        mpi: [spectrum-mpi]
        pkgconfig: [pkg-config]
      buildable: true
      version: []
      target: []
    spectrum-mpi:
      externals:
      - spec: spectrum-mpi@10.3.1.2%gcc%9.1.0
        modules:
        - spectrum-mpi/10.3.1.2-20200121
      buildable: false
      version: []
      target: []
      providers: {}
      compiler: []
    openssl:
      externals:
      - spec: openssl@1.0.2k
        prefix: /usr
      buildable: false
      version: []
      target: []
      providers: {}
      compiler: []
    autoconf:
      externals:
      - spec: autoconf@2.69
        prefix: /usr
      buildable: false
      version: []
      target: []
      providers: {}
      compiler: []
    automake:
      externals:
      - spec: automake@1.13.4
        prefix: /usr
      buildable: false
      version: []
      target: []
      providers: {}
      compiler: []
    libtool:
      externals:
      - spec: libtool@2.4.2
        prefix: /usr
      buildable: false
      version: []
      target: []
      providers: {}
      compiler: []
    ucx:
      externals:
      - spec: ucx@1.5.1
        prefix: /usr
      buildable: false
      version: []
      target: []
      providers: {}
      compiler: []
    libnl:
      externals:
      - spec: libnl@3.3.0
        modules:
        - libnl/3.3.0
      buildable: false
      version: []
      target: []
      providers: {}
      compiler: []
    rdma-core:
      externals:
      - spec: rdma-core@20
        prefix: /usr
      buildable: false
      version: []
      target: []
      providers: {}
      compiler: []
    mercury:
      variants: ~boostsys
      buildable: true
      version: []
      target: []
      providers: {}
      compiler: []
    libfabric:
      variants: fabrics=verbs,rxm
      buildable: true
      version: []
      target: []
      providers: {}
      compiler: []
  view: true