setup.py 1.59 KB
Newer Older
1
2
3
#!/usr/bin/env python
# -*- coding: utf-8 -*-

4
5
6
from setuptools import setup, find_packages, Extension
import sys

7
8
9
10
11

with open('README.rst') as readme_file:
    readme = readme_file.read()


12
requirements = ['cffi', 'numpy', 'pandas', 'matplotlib']
13
14
15
16
setup_requirements = ['pytest-runner', ]
test_requirements = ['pytest']


17
18
19
20
21
22
23
24
25
26
27
28
29
ext_modules = []

if '--with-extension' in sys.argv:
    ext_modules.append(Extension(
        'darshan.extension',
        #optional=True,
        sources=['darshan/extension.c'],
        include_dirs=['/usr/include'],
        libraries=['darshan-util']
        ))
    sys.argv.remove('--with-extension')


30
31
32
33
setup(
    author='',
    author_email='',
    classifiers=[
34
        'Development Status :: 4 - Beta',
35
        'Intended Audience :: Developers',
36
        'Intended Audience :: Science/Research',
37
38
39
40
        'Natural Language :: English',
        'Programming Language :: Python :: 3',
        'Programming Language :: Python :: 3.6',
        'Programming Language :: Python :: 3.7',
41
        'Programming Language :: Python :: 3.8',
42
        'Programming Language :: Python :: 3.9'
43
44
    ],
    description="Python tools to interact with darshan log records of HPC applications.",
45
    long_description=readme,
46
    ext_modules = ext_modules,  
47
48
49
50
    install_requires=requirements,
    include_package_data=True,
    keywords='darshan',
    name='darshan',
51
    packages=find_packages(include=['darshan*']),
52
53
54
55
    setup_requires=setup_requirements,
    test_suite='tests',
    tests_require=test_requirements,
    url='https://www.mcs.anl.gov/research/projects/darshan/',
56
    version='0.0.6',
57
58
    zip_safe=False,
)